View Single Post
      12-02-2012, 01:55 PM   #27
yannisap
New Member
 
Drives: F30 320d
Join Date: Sep 2012
Location: AGR

Posts: 8
iTrader: (0)

Quote:
Originally Posted by bmw328jc
I was driving to work in Eco pro mode and once i entered the highway, i tried to catch up on speed so I moved the gear to DS from D position and all of a sudden the car jammed up, started shaking and a signal came up in the iDrive saying Drivetrain malfunction, drive moderately, and the car wouldn't allow me to exceed 50 mls/h. The car kept shaking till I took the next exit. It was very dangerous as I entered the highway with that speed and there was a bunch of cars going at least 75 mls/hr that had to leave the lane I'm on. Darn it. The engine light is on now. I parked the car and I'm at work now. WTF!!
Quote:
Originally Posted by ONE-77 View Post
this has happened to my car 4 times now. Its a cylinder misfire that causes that error. It could either be a spark plug, coil pack or injector. The dealer has replaced the coil packs and spark plugs but it continues to happen. BMWNA is involved now and they have no idea what to do fix it. They have updated software as well with no luck. Im one step away from filing a lemon law suit for it.
Same problem we had on a colleague's car. We took it to various BMW and all followed the procedure by replacing everything then at our desperate call to the leasing company they suggested another dealer who immediately said that the problem was by the thermostat. It is common for the BMW's that the thermostat during the winter stacks and doesn't allow the systems to understand how to operate properly the engine. It is also the reason that the computer cannot record any problem.
yannisap is offline  
0
Reply With Quote